New X Owner - Page 2 - Second Generation Nissan Xterra Forums (2005+)
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 20 (permalink) Old 07-08-2019, 08:08 AM
Veteran & LPM
2010 ❌terra S & 2010 Frontier SE
 
VMBiohazard's Avatar
 
Join Date: Jun 2015
Location: PA
Posts: 7,635
Garage
Welcome from PA!

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
VMBiohazard is offline  
Sponsored Links
Advertisement
 
post #12 of 20 (permalink) Old 07-10-2019, 02:57 PM Thread Starter
TNX Realm Noobie
2005 Xterra SE
 
Join Date: Jul 2019
Location: Clearfield, UT
Posts: 21
Thanks!!
peregrinus is offline  
post #13 of 20 (permalink) Old 07-10-2019, 11:55 PM
TNX Realm Noobie
 
Join Date: Jun 2019
Posts: 15
Welcome
D.MNI3 is offline  
 
post #14 of 20 (permalink) Old 07-11-2019, 09:04 PM Thread Starter
TNX Realm Noobie
2005 Xterra SE
 
Join Date: Jul 2019
Location: Clearfield, UT
Posts: 21
Do you think this is a aftermarket radiator?
Attached Images
File Type: jpeg 6D2E038A-2784-4F88-94D7-7AAEEF6391AA_1562893432867.jpeg (1.28 MB, 15 views)
peregrinus is offline  
post #15 of 20 (permalink) Old 07-11-2019, 11:38 PM
Veteran
2011 Avalanche White Xterra S - Tonka
 
Brunnie's Avatar
 
Join Date: Aug 2014
Location: Colorado Springs, Colorado
Posts: 1,495
Quote:
Originally Posted by peregrinus View Post
Do you think this is a aftermarket radiator?
With square corners it could be, I'll have to look at mine tomorrow and see how it is shaped.

There are no part numbers or a name anyplace on it?

No matter where you go, there you are.
I never get lost, I have adventures.

Click Here for >
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brunnie is offline  
post #16 of 20 (permalink) Old 07-11-2019, 11:41 PM
Veteran
2011 Avalanche White Xterra S - Tonka
 
Brunnie's Avatar
 
Join Date: Aug 2014
Location: Colorado Springs, Colorado
Posts: 1,495
Quote:
Originally Posted by peregrinus View Post
Found the model number it's not listed as an effected one. Let me know what you think.
92100 EA500
A7 A0702002

I think this is for the ac unit?
That is the P/N for the air conditioner condenser, not the radiator.

No matter where you go, there you are.
I never get lost, I have adventures.

Click Here for >
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brunnie is offline  
post #17 of 20 (permalink) Old 07-12-2019, 10:53 AM Thread Starter
TNX Realm Noobie
2005 Xterra SE
 
Join Date: Jul 2019
Location: Clearfield, UT
Posts: 21
Yeah no part numbers that I could find so far.. Replaced the serpentine belt last night and did not see any part numbers for the radiator..
peregrinus is offline  
post #18 of 20 (permalink) Old 07-12-2019, 12:21 PM
Veteran
2011 Avalanche White Xterra S - Tonka
 
Brunnie's Avatar
 
Join Date: Aug 2014
Location: Colorado Springs, Colorado
Posts: 1,495
OK, I just checked my radiator and could tell that you didn't take a picture of the whole thing, that's why it looked a bit odd.
So I took 3 photos.
One shows that my radiator looks like yours. One shows the P/N tag just to the right of the radiator cap. The third shows some numbers that are molded into the top tank just to the right of the radiator cap, and just left of the P/N tag.

(No comments on how dusty the engine is, either. )
Attached Images
File Type: jpg R1.jpg (76.4 KB, 2 views)
File Type: jpg R2.jpg (60.8 KB, 2 views)
File Type: jpg R3.jpg (52.2 KB, 2 views)

No matter where you go, there you are.
I never get lost, I have adventures.

Click Here for >
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brunnie is offline  
post #19 of 20 (permalink) Old 07-12-2019, 01:52 PM Thread Starter
TNX Realm Noobie
2005 Xterra SE
 
Join Date: Jul 2019
Location: Clearfield, UT
Posts: 21
Thanks.. Weird mine has none of those markings?
Whats everyone's thoughts on this?
Should I do the bypass?
Do you think this is aftermarket? And its good to go?
peregrinus is offline  
post #20 of 20 (permalink) Old 07-12-2019, 08:05 PM
Noobie
 
Roaddawg's Avatar
 
Join Date: Jul 2019
Location: Firth, ID
Posts: 2
I'm in St.George..Riverside Auto has always done good work on my X..If your local drop me a line.
Roaddawg is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > Regions > Mountain

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome