Nip/Tuck for Rear Carrier Build? - Second Generation Nissan Xterra Forums (2005+)
 3Likes
  • 1 Post By Mr_Scott
  • 1 Post By jsexton
  • 1 Post By NYTKSHR
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-19-2016, 10:05 PM Thread Starter
Veteran
2013 Glacier White Xterra Pro-4X 6MT TS'd & 4.56's
 
Mr_Scott's Avatar
 
Join Date: Dec 2012
Location: Spanish Springs, NV
Posts: 1,135
Nip/Tuck for Rear Carrier Build?

So, I have an idea of how I want this rear bumper/carrier to work but it's going to require some surgery to get rid of some useless parts of the cab. Yes, scary but it would be super stout and I've hit this area on multiple occasions. I'd plate it all back up when I was done cutting, of course.

Has anyone done or attempted this on an X:


I'm thinking I want to tie the ends of the bumper back into the frame but the lower section shown will need to go from both sides. It's already kinda hammered so might as well lose it, right?
Hamman likes this.
Mr_Scott is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-19-2016, 10:58 PM
Lifetime Premium Member
2015 Brilliant Silver 6MT Pro-4X & 2007 Avalanche White S 5AT 4x4 ❌terras
 
jsexton's Avatar
 
Join Date: Feb 2012
Location: Lewis Center, OH
Posts: 9,933
Garage
mtdewmike might have. If he did, it was probably not anywhere near the extent you are taking about.

https://www.thenewx.org/forum/30-xter...oad-armor.html
Mr_Scott likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- J.J. Watt
”You are free to choose, but you are not free from the consequence of your choice.”


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jsexton is offline  
post #3 of 10 (permalink) Old 04-20-2016, 12:42 AM
Veteran
2011 Super Black Xterra S Plus
 
NYTKSHR's Avatar
 
Join Date: Mar 2011
Location: Las Vegas, NV
Posts: 2,229
If you cut both sides off make sure you find another place for the pressure vents or closing your doors and running the vent fan and AC will be a real bitch.
Mr_Scott likes this.
NYTKSHR is offline  
 
post #4 of 10 (permalink) Old 04-20-2016, 09:50 AM Thread Starter
Veteran
2013 Glacier White Xterra Pro-4X 6MT TS'd & 4.56's
 
Mr_Scott's Avatar
 
Join Date: Dec 2012
Location: Spanish Springs, NV
Posts: 1,135
Quote:
Originally Posted by NYTKSHR View Post
If you cut both sides off make sure you find another place for the pressure vents or closing your doors and running the vent fan and AC will be a real bitch.
Definitely. Going to try to find a better, easily filtered location.
Mr_Scott is offline  
post #5 of 10 (permalink) Old 04-20-2016, 09:52 AM
Veteran & LPM
2010 ❌terra S & 2010 Frontier SE
 
VMBiohazard's Avatar
 
Join Date: Jun 2015
Location: PA
Posts: 7,632
Garage
Sub'd

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
VMBiohazard is offline  
post #6 of 10 (permalink) Old 04-20-2016, 03:54 PM
West North Central Regional Moderator
2006 Solar Yellow - ew3 Xterra S
 
Deltaphi216's Avatar
 
Join Date: Aug 2006
Location: O'Fallon, MO (Suburb of STL)
Posts: 9,789
interesting...
Deltaphi216 is offline  
post #7 of 10 (permalink) Old 04-20-2016, 04:05 PM
Veteran
2007 Super Black Xterra S Titan Swapped!
 
GPD605X's Avatar
 
Join Date: Apr 2010
Location: Gulfport, MS
Posts: 3,899
Garage
Is it me or is the pic not working? A lot of images haven't been working for me since I had to reinstall windows
GPD605X is offline  
post #8 of 10 (permalink) Old 04-20-2016, 07:53 PM Thread Starter
Veteran
2013 Glacier White Xterra Pro-4X 6MT TS'd & 4.56's
 
Mr_Scott's Avatar
 
Join Date: Dec 2012
Location: Spanish Springs, NV
Posts: 1,135
Quote:
Originally Posted by GPD605X View Post
Is it me or is the pic not working? A lot of images haven't been working for me since I had to reinstall windows
Works fine for me at home. At work the I.T. dept. has it pretty locked down and all I ever get to see is text.
Mr_Scott is offline  
post #9 of 10 (permalink) Old 04-20-2016, 11:53 PM
Veteran
2011 Super Black Xterra S Plus
 
NYTKSHR's Avatar
 
Join Date: Mar 2011
Location: Las Vegas, NV
Posts: 2,229
Quote:
Originally Posted by GPD605X View Post
Is it me or is the pic not working? A lot of images haven't been working for me since I had to reinstall windows
Are you using some addblock program? Might be you are blocking photobucket.
NYTKSHR is offline  
post #10 of 10 (permalink) Old 04-20-2016, 11:53 PM
Veteran
2007 Super Black Xterra S Titan Swapped!
 
GPD605X's Avatar
 
Join Date: Apr 2010
Location: Gulfport, MS
Posts: 3,899
Garage
Not sure. I'll look into it


Sent from my couch
GPD605X is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > Xterra Tech Topics > Exterior

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome