Help with Greasable U-joint Install - Second Generation Nissan Xterra Forums (2005+)
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-13-2019, 12:54 PM Thread Starter
Veteran
2008 Avalanche White Xterra S
 
idn88's Avatar
 
Join Date: Oct 2011
Location: South Carolina
Posts: 1,359
Help with Greasable U-joint Install

So, I am trying to install front u-joints. I ordered spicer greasable - I have them in my X, this is my Fronty. There going in fine, but I am having some questions/ issues with the clips.

First, the clips that came out of mine measure 0.063 inches thick - they have a bit of green paint left on them. The new green ones are only 0.061 inches - so 0.002 thinner. So, the old ones looked OK so I re-used them, but I am wondering if that is a good idea. I don't like to use them, but another .002 on each side sounds worse?

The second issue is they included only 3 clips - not 4. There is usually a 4th clip that is shaped different to accommodate the grease zirk.

All 4 joints I ordered from Rock Auto are like this front and back - sealed packaging with only 3 of each type clip / none of the special clip - so must be quality issue? Its like the normal clips without the right hook / tab that blocks the zirk hole. I simply bent one a bit after install the make room for the zirk. Now I am wondering if that was an OK idea?

So I am kind of in the middle of this now (or back to it tonight actually). Suggestions?



idn88 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-13-2019, 01:27 PM
Veteran
2006 Super Black Xterra S
 
General_Tarfun's Avatar
 
Join Date: Sep 2013
Location: Atlanta, GA
Posts: 2,622
Garage
It's probably fine to re-use those retainer clips as long as they spring into place ok and fit securely but I think the clips with green paint are aftermarket? Trying to remember but I think the last time I did Spicer u-joints they came with two packs of clips and I didn't use the green ones.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
General_Tarfun is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > Xterra Tech Topics > Powertrain & Driveline

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How-to: Remove OEM Leaf Springs and Install General Springs Leafs Longboardr How-to's 15 05-22-2019 03:28 PM
How-to: ShrockWorks Front Bumper Install - PBR usmc xterra How-to's 129 02-09-2019 01:43 PM
How-to: SPC UCA Install Dyno992 How-to's 3 01-14-2019 09:35 PM
How-to: Install Daystar Lift - PBR usmc xterra How-to's 111 08-21-2017 02:07 PM
Pioneer AVIC-D3 Install Completed (LONG) ScottS Electrical 50 03-28-2017 10:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome