Two Questions on Installing new Clutch... - Second Generation Nissan Xterra Forums (2005+)
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-21-2017, 01:50 AM Thread Starter
Noobie
 
Join Date: Mar 2007
Location: Jacksonville
Posts: 49
Two Questions on Installing new Clutch...

I'm having a mechanic friend install in a JWT CLUTCH (for the larger 275mm engagement) and a LUK DM flywheel (seems like it'll be smoother and all I do is commute).

Is there anything else I need to get and have him change while we have the clutch out (so that I can save on labor)? Someone mentioned that replacing some kind of pump (?) might be smart.

Also, where can I find a kit containing the pilot bushing, throw out bearing, and alignment tool?
whatgorilla is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-21-2017, 09:15 AM
Veteran
2005 Super Black Xterra Off-Road 6MT
 
NOAHVT's Avatar
 
Join Date: Mar 2010
Location: Enfield, NH
Posts: 2,165
I bought my pilot bushing, throw out bearing and alignment tool all separate.

I bought my clutch alignment tool here: http://www.clutchtools.com/

Here are the other parts: http://shop.advanceautoparts.com/p/n...ontent=general
http://shop.advanceautoparts.com/p/k...ontent=general

You will also need this: https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by NOAHVT; 04-21-2017 at 09:25 AM.
NOAHVT is offline  
post #3 of 4 (permalink) Old 04-21-2017, 10:41 AM Thread Starter
Noobie
 
Join Date: Mar 2007
Location: Jacksonville
Posts: 49
Thanks!!!

I ordered both parts and the alignment tool (TP55 is out of stock until next Thursday, so I'll keep looking for one I can get on MON or TUE).

You didn't replace any other parts while you had the clutch out?
whatgorilla is offline  
 
post #4 of 4 (permalink) Old 04-21-2017, 11:48 AM
Veteran
2005 Super Black Xterra Off-Road 6MT
 
NOAHVT's Avatar
 
Join Date: Mar 2010
Location: Enfield, NH
Posts: 2,165
I had the entire engine out so I replaced the primary cats and motor mounts as well. nothing else I don't think though.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NOAHVT is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > Xterra Tech Topics > Powertrain & Driveline

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome