Throttle Bottle Idle Air Re-learn - Page 7 - Second Generation Nissan Xterra Forums (2005+)
Reply
 
LinkBack Thread Tools Display Modes
post #61 of 94 (permalink) Old 01-24-2012, 11:39 PM
Senior Member
2008 Xterra S
 
cuttingman423's Avatar
 
Join Date: Jan 2011
Location: Lancaster Pennsylvania
Posts: 100
this is the only down fall to all this new high tech computerized stuff ....kinda miss the good old days of vehicles without all the fancy crap was much easier to work on LOL
cuttingman423 is offline  
Sponsored Links
Advertisement
 
post #62 of 94 (permalink) Old 04-21-2012, 03:04 PM
Veteran
2007 Night Armor Xterra S
 
Killswitch's Avatar
 
Join Date: Jan 2011
Location: North Carolina
Posts: 5,477
Stupid question but in this How-to for the IAVL, what does "MIL" mean? It refers to waiting for MIL to stop blinking and turn to ON. What exactly is blinking? Sounds dumb but I dont know that particular terminology
Killswitch is offline  
post #63 of 94 (permalink) Old 04-21-2012, 07:09 PM
Veteran
2006 T-Swap Lightning Silver Xterra OR 4x4
 
AZ-Ted's Avatar
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 3,250
Quote:
Originally Posted by Killswitch View Post
Stupid question but in this How-to for the IAVL, what does "MIL" mean? It refers to waiting for MIL to stop blinking and turn to ON. What exactly is blinking? Sounds dumb but I dont know that particular terminology
"MIL" = Malfunction Indicator Lamp - aka Check Engine Light (CEL) aka Service Engine Soon (SES) light.
AZ-Ted is offline  
post #64 of 94 (permalink) Old 04-21-2012, 07:38 PM
Veteran
2007 Night Armor Xterra S
 
Killswitch's Avatar
 
Join Date: Jan 2011
Location: North Carolina
Posts: 5,477
haha alright, that is what I figured. That is what I used, got it actually right 3 times I believe, to where it went through it's little phases and then went solid. The light would stay off for maybe two starts and then come back on, looks like I need to go ahead and look at some other issues. Thanks.
Killswitch is offline  
post #65 of 94 (permalink) Old 04-26-2012, 05:57 PM
Veteran
2009 Equator RMZ-4
 
Join Date: Sep 2010
Location: Shamong, NJ
Posts: 3,006
I think I need to do this, got a P0172 code. Already cleaned the MAF, and my filter. Still keeps throwing codes. Hopefully I can resolve this at home, don't really like my dealership service dept.
ducatidom is offline  
post #66 of 94 (permalink) Old 07-17-2012, 03:13 AM
Noobie
2006 Xterra S
 
Join Date: Feb 2008
Location: OKC, OK
Posts: 5
The PNP switch is referring the Park/Neutral position switch.. For it to be ON:
Auto Trans - Park or Neutral, Manual Trans - Neutral

Here's a cool graphic from the service manual that shows the process for entering the "idle air volume learning" mode if this helps anyone..

dollarlongnecks is offline  
post #67 of 94 (permalink) Old 07-21-2012, 04:36 AM
Senior Member
2006 Xterra S
 
JoseX's Avatar
 
Join Date: Mar 2011
Location: Muskegon, MI
Posts: 116
Quote:
Originally Posted by dollarlongnecks View Post
The PNP switch is referring the Park/Neutral position switch.. For it to be ON:
Auto Trans - Park or Neutral, Manual Trans - Neutral

Here's a cool graphic from the service manual that shows the process for entering the "idle air volume learning" mode if this helps anyone..

At first that diagram made no sense. But after looking at it, it does almost make it easier.
JoseX is offline  
post #68 of 94 (permalink) Old 08-31-2012, 01:28 AM
West North Central Regional Moderator
2006 Solar Yellow - ew3 Xterra S
 
Deltaphi216's Avatar
 
Join Date: Aug 2006
Location: O'Fallon, MO (suburb of STL)
Posts: 9,075
Quote:
Originally Posted by Melmeister View Post
After attempting a few times (2 days :P) I figured i was doing something wrong. Duh!
I grabbed a stop watch and made a simple calculation. It worked the first time, so I unplugged the TB again to re try it (haha) hoping that it worked again just in case i ran into this again and it did. So i gave it a third try and work again.
Normal way:
Start engine and warm it up to normal operating temperature.
4. Check that all items listed under the topic PREPARATION (previously mentioned) are in good order.
5. Turn ignition switch OFF and wait at least 10 seconds.
6. Confirm that accelerator pedal is fully released, then turn ignition switch ON and wait 3 seconds.
7. Repeat the following procedure quickly five times within 5 seconds.
a. Fully depress the accelerator pedal.
b. Fully release the accelerator pedal.
8. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 20 seconds until the MIL stops
blinking and turned ON.
9. Fully release the accelerator pedal within 3 seconds after the MIL turned ON.
10. Start engine and let it idle.
11. Wait 20 seconds.
12. Rev up the engine two or three times and make sure that idle speed and ignition timing are within the
specifications.

My Way with time watch
Now, this is how I did it and hope this will be a easier way to understand how to do it.
00:00 Turn key to ign. on
00:03 Press gas pedal 5 times (all the way down and realease) before 5 sec. (00:08)The total 5sec. Now wait 7 sec. more
This is were i think i was going wrong before, I was pressing the pedal 5 times and did not take into consideration that even if it took me 3 sec to press the pedal 5 times you STILL have to wait the hole 5 sec. before going onto waiting for the next 7 sec.
00:15 Press and hold the gas pedal until the MIL light goes solid, once this happens release gas pedal and start engine.
Let it idle and you should be good to go

idle relearn completed! the shortbus hasn't idled this low in years. CEL is out too. only took me 3 tries using this method. easy peasy!

Click HERE to Ride the Short Bus - XBL: Tom Brunansky
Quote:
Originally Posted by equinox764 View Post
i love how at the GPAX mod days our rigs (speaking about ROOK) were equal sliders, spacers aal, fangars light bars, pio dvd headunits, etc... now your truck has just launched into space and my truck is at a drive up bank trying to order a hotdog because he cannot read.
Deltaphi216 is offline  
post #69 of 94 (permalink) Old 09-04-2012, 04:17 PM
Senior Member
2006 Xterra X
 
Join Date: Nov 2011
Location: Central Il
Posts: 166
what is the MIL light?

06 X 6spd
haunter is offline  
post #70 of 94 (permalink) Old 09-04-2012, 04:21 PM
Veteran
2007 Night Armor Xterra S
 
Killswitch's Avatar
 
Join Date: Jan 2011
Location: North Carolina
Posts: 5,477
^look 4 posts above yours at posts 62,63, and 64
Killswitch is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > Xterra Tech Topics > Powertrain & Driveline

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome